Forum

Thema: Bekanntes 10212-Installation Problem ABER... [Gelöst - FAQ?]  (Gelesen 5678 mal)

Zündkerzenwachs

  • Private
  • *
  • Beiträge: 4
    • Profil anzeigen
Hi,

Ich habe hier vor mir ein frisches Exemplar der CoH-Anthology vor mir liegen aber ich hab das Problem, dass ich es auf meinem Rechner nicht installieren kann. Auf einem anderen gehts - daher ist die DVD schonmal in Ordnung.

Wenn ich die Installation starte kommt bei 2% die Fehlermeldung, dass er die benötige redistributable nicht installieren kann. Fehlercode 10212. So ich habe gegoogelt und hier im Forum gesucht und entsprechend einiges zu diesem Fehlercode gefunden samt verschiedener Lösungansätze. Allerdings funktionieren diese bei mir nicht bzw. ich habe keinen Schimmer wie ich diesen Lösungansatz ausführen soll. Dazu möcht ich noch einiges im folgenden Abschnitt sagen.

Zum Hintergrund: Vor der Anthology hatte ich die CoH-Demo drauf und die hatte ich ganz normal "sauber" über die Un-Installation deinstalliert. Es scheint nun aber so als wäre dennoch nicht alles draußen - sonst würde der Fehlercode nicht kommen. Als Problemlösung für diesen Fehlercode wird oft das Clean-Up Utility empfohlen. Allerdings nützt mir das nix weil alles deinstalliert ist. Bei den installierten Programmen steht die CoH-Demo ordnungsgemäß auch nicht mehr drin, so dass ich nun dieses Tool bemühen könnte. Desweiteren bin ich was solche "Übrigbleibsel" auch kein unbgeschriebenes Blatt. Ich habe einige Tools für solche Probleme und schon oft weitaus komplexere und größere nicht ordentlich deinstallierte Software aus der Registry rausbekommen. Hier muss ich aber irgendwie passen. Meine Tools finden zwar Einträge zu "Company of Heroes" aber wenn ich mir die Einträge anschaue, dann frage ich mich warum diese gefunden wurden weil dort nur HexDez-Folgen drin sind. D.h. ich kann nicht mit sicherheit sagen ob die diese Einträge dazu gehören und ob ich bei mir bei Löschnung nicht was zerschieße. Die Einträge befinden sich in HKEY_CURRENT_USER->Software-Classes->... Crap-Cleaner und Tune-Up laufen sowieso vor allen Versuchen drüber.

An anderer Stelle wird erwähnt, man solle doch ein anderes Benutzer-Konto verwenden. Das löst das Problem leider auch nicht. Eine weitere Lösung soll anscheinend sein, dass man den Schreibschutz des Temp-Ordners entfernt. Geht leider nicht wirklich weil dort immer wieder des Kästchen ausgefüllt erscheint, wenn man diese Eigenschaft ändert. Egal wie oft man das macht. Die Ordner im Temp-Ordner selber sin nicht schreibgeschützt.

Meine Vermutung wäre, dass das Setup versucht die Redist. zu installieren aber der Redist-Install abbricht, weil sie schon installiert ist. Naja nur ne Vermutung. Ich habe es geschafft diesen Redist-Installer im Temp-Ordner zu sichern bevor er gelöscht wurde durch den Installations-Abbruch. Hab den mal seperat ausgeführt aber der meckert dann, die Install-Quelle befindet sich auf einer nicht verfügbaren Netzwerk-Ressource. Wundert mich irgendwie, was das soll. Auf einem Rechner funktioniert die Installation wie gesagt. Allerdings war das ein XP-32-Bit und ich nutze Windows 7 64-Bit.

Im übrigen habe ich natürlich schon alle Scherzchen von wegen Kompatibilität durchprobiert.

Mir gehen ehrlich gesagt die sinnvollen Optionen aus. Meine letzte Option wäre, nochmal probieren die Demo zu installieren, ein Tool mitlaufen zu lassen welches alles Installations-Aktionen mitloggt und damit nochmal die De-Installation zu probieren. Das ist allerdings n bisschen zeit-aufwändig, weil ich dazu erstmal das Tool wieder raussuchen, die Demo runterladen, etc muss.

Währenddessen würde ich gerne hören, ob ihr nicht noch weitere Lösungs-Vorschläge habt bzw. ob ich welche übersehen hab.
« Letzte Änderung: 20. April 2011 - 18:40:24 von Zündkerzenwachs »

Zündkerzenwachs

  • Private
  • *
  • Beiträge: 4
    • Profil anzeigen
Re:Bekanntes 10212-Installation Problem ABER... [Gelöst - FAQ?]
« Antwort #1 am: 20. April 2011 - 18:52:22 »
Ich habe mein Problem gelöst. Es lag tatsächlich daran, dass die Demo eine Visual 2005 Redistributable installiert aber nicht wieder deinstalliert hatte.

Diese eine Redistributable ist ca. 2,69 mB und muss deinstalliert werden sonst bekommt man diese Fehlermeldung wie ich, obwohl man alles vorher sauber deinstalliert hatte. Ich hatte vorher sogar die Demo RevoUninstaller installiert und wieder deinstalliert. Bei dieser zweiten Installation blieb aber Redist außen vor weil sie schon drauf war und das Demo Setup hat das erkannt (im Gegensatz zum Anthology-Setup - wie bitter). Daher blieb sogar der Revo nutzlos.

Ich schreibe bei Gelegenheit noch eine ausführlichere Problemlösung, sofern ihr das ins FAQ aufnehmen wollt (wäre vlt. angeraten dass zu tun). Da gibt eine Sache, die n bisschen tricky ist.

Also das Problem war nicht nett... War schon fast so, wie ne verkackte CosmosWorks Installation sauber vom Rechner zu kicken.

Edit:
Genauere Beschreibung:

Anm.: Getestet unter Windows 7 64-Bit mit dem Setup der CoH-Anthology. CoH-Demo vorher "sauber" installiert/deinstalliert.

Problem: "Installation gescheitert"-Meldung kommt bei 2% der Installation mit dem Fehlercode 10212. Das Setup meldet: "Beim installieren des Windows-Installationspakets "<Pfad zu einem Ordner im Temp-Ordner des Benutzers> ist ein Fehler aufgetreten [...] (Fehlererkennung 10212:0000064c (MsiInstallProductW meldete 0000064c: Die Installationsquelle für dieses Produkt ist nicht verfügbar.[...]"

D.h. das Setup hat ein Problem mit der Installation der Redistributable. Selbige ist höchstwahrscheinlich schon installiert und damit kann das Setup nicht umgehen. Es bricht ab.

Lösung: Die Redistributable muss deinstalliert werden leider ist das einfacher gesagt als getan. Bei mir hat Windows das verweigert, weil es das .msi-Paket dazu nicht gefunden hat. Dieses Paket wird aber benötigt. Ich könnte es hochladen aber mit etwas Timing empfiehlt sich folgendes Vorgehen:

1. Started das CoH-Setup und merkt euch den Pfad des Redist-Pakets, welches die Setup-Fehlermeldung angibt.

2. Wenn ihr dort ankommt wird das Paket schon wieder gelöscht sein durch das Setup. Daher löscht alles im Temp-Ordner und lasst das Ordner-Fenster offen. Löschen deswegen damits überischtlich wird.

3. Startet das Setup neu und wenn selbiges versucht die Redistributable zu installieren, findet flott veraus, wo die .msi  dieser Redist im Temp-Ordner liegt. Der Ordner im Temp-Ordner ist recht kryptisch benannt. In diesem Ordner wiederum wird das Setup einen Ordner "00000001_TEMP" oder so ähnlich anlegen. Dort müsste die .msi samt allem benötigtem drin sein. Am besten kopiert den gesamten Ordner.
Und das alles bevor die Fehlermeldung kommt.

4. Geht nun in die Systemsteuerung.

5. Deinstalliert die "Microsoft Visual C++ 2005 Redistributable" (das ist der komplette Name - keine kryptischen Ziffernfolgen dahinter!). Diese muss 2,69 mB groß sein.

6. Die Deinstallationsroutine wird meckern, dass das .msi Paket fehlt und wird euch einen Dialog anbieten, wo ihr den Pfad zu diesem Paket angeben könnt. Sucht jetzt den Pfad zu dem Ort, wo ihr das Zeug aus dem Temp-Ordner hinkopiert habt.

7. Jetzt kann die Deinstallation fortgesetzt werden.

8. Nach diesem ganzen Prozedere startet ihr die CoH-Installation neu und diesmal sollte es funktionieren.

Falls jemand einen einfacheren Weg weiß, diese Redist zu entfernen bitte hier posten. Das was ich beschrieben hab, dürfte für manche zu schwierig sein.
« Letzte Änderung: 20. April 2011 - 20:07:20 von Zündkerzenwachs »

Camini

  • Private
  • *
  • Beiträge: 1
    • Profil anzeigen
Re:Bekanntes 10212-Installation Problem ABER... [Gelöst - FAQ?]
« Antwort #2 am: 18. Juli 2012 - 11:53:41 »
Ich würde gerne diesen Thread wieder ausgraben, da er exakt die Probleme mit CoH Anthology beschreibt, welche ich auch habe und ich finde auch sonst nur immer wieder genau diesen Thread hier. Bessere Hilfestellungen bietet weder die WWW sufu noch die im Forum hier.
Ich habe nun schon ettliches an Zeit investiert, sämmtliche Lösungsideen angesetzt
  • Kompatibilität zu xp SP1
  • Ausführen als Admin
  • Registry cleaning
  • anderer user acc.
  • VC Redist deinstalliert:
    Leider hilft bei mir die Deinstallation der 2005er VCRedist (x86 mit 2,69MB) nicht- laut Windows Programmverzeichnis: Version 8.0.56336 - welches der VCRedist 2005 SP1 entspricht (also der aktuellsten der 2005er wenn ich sie bei MS lade).
    Diese kann ich problemlos installieren und deinstallieren (Auch installiert CoH per Setup diese wenn ich sie deinstalliere zuvor). Die 64bit Variante hatte ich ebenso mal testweise gleich mit rausgenommen.

Das Problem was ich sehe - und gerne hier aufschlüsseln möchte - das Setup durchläuft ja mehrere Schritte.
Im Installer sieht man auch per Text, was gerade geschieht:
  • Setup-Text "DirectX wird konfiguriert": :
    es entsteht eine 00000001_TEMP Datei, dann ein Ordner, ausserhalb vom Ordner "in Temp" entstehen temp-Dateien für die Installationsroutine dirextX:
    ergo 00000001_TEMP = Installation DirectX
  • Setup-Text "MS C/C++ runtime wird konfiguriert":
    es entsteht identisch zu 1. 00000002_TEMP, die Installation entspricht MS Visual C++ 2005 x86 (v8.0.56336 = aktuellste mit sp1)
  • Setup-Text: "kompatibilitätskomponenten für das vorige Installationsprogramm werden konfiguriert" (siehe screenshot):
    es entstehen die Dateien 00000003_TEMP und 00000004_TEMP.
    Es werden keine Unterordner angelegt (oder ich sehe sie nicht da schon wieder gelöscht)
    das Setup bricht mit dem 20212 error ab und verweist auf  00000004_TEMP (siehe 2. Screenshot)

So - was ich nun wissen will :) WAS verdammt nochmal PASSIERT BEI  00000004_TEMP ???
:)

edit: ich habs nochmal mit mitgeloggt und die genauen Texte im Setup abgetippt und screens gemacht.
« Letzte Änderung: 18. Juli 2012 - 12:09:27 von Camini »